Home
Products
Downloads
Support
Buy
Loading the WebPropertyGrid for ASP.NET MVC assembly in your web application
Product Name: WebPropertyGrid for ASP.NET MVC
Product Version: 1.0
Document Type: Informational
Last Updated: 8/9/2017
Document ID: 144
Summary
How to load the WebPropertyGrid assembly if you are having trouble.

Details

The WebPropertyGrid assemblies are designed to target the major version of ASP.NET MVC in which they are designed. For example, if you are using ASP.NET MVC 5 the correct WebPropertyGrid assembly for this platform was compiled using ASP.NET MVC 5.0.0.0.

This can create a binding issue if your web site is built using an updated version of ASP.NET MVC. For example, your web application might be using the latest version of this platform, which is ASP.NET MVC 5.2.3.0.

In order to use the WebPropertyGrid assembly in your web application, you can add a mapping from the old version to the new version by updating your web.config file. Below is a sample web.config file that contains this mapping from 5.0.0.0 to 5.2.3.0 in bold. Adding this XML element to your web.config file should allow the WebPropertyGrid assembly to load correctly in your web application.

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <appSettings>
    <add key="webpages:Version" value="3.0.0.0" />
    <add key="webpages:Enabled" value="false" />
    <add key="ClientValidationEnabled" value="true" />
    <add key="UnobtrusiveJavaScriptEnabled" value="true" />
  </appSettings>
  <system.web>
    <compilation debug="true" targetFramework="4.5" />
    <httpRuntime targetFramework="4.5" />
  </system.web>
  <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="5.0.0.0" newVersion="5.2.3.0" />
      </dependentAssembly>
    </assemblyBinding>
  </runtime>
</configuration>
Copyright © 2022 Coalesys, Inc. All Rights Reserved.